Any select-o-speed owners?

This forum is about the Ford World Series.

Any select-o-speed owners?

Postby 5000blues » Tue Apr 03, 2018 1:15 pm

Somebody nearby found a 5000 selectospeed in a barn and has it running, but it's not a pretty sight. It's driving ok after being idle for 30 years, but we need a bit more info on using it. I drove it, all the gears work but it runs away going downhill. Does anyone here know what causes this?

Also is modern multi purpose oil ok or does it need anything special? I'm fairly positive an oil change might be beneficial after 30 years. Sorry no pics yet. Are filter(s) still available? Thanks in advance for any info.
If the seat is wet, sit on your hat, better to have a cool head than a wet arse
5000blues
Not Quite Blue Yet
 
Posts: 33
Joined: Fri Aug 07, 2009 8:40 pm
Location: S Ireland

Re: Any select-o-speed owners?

Postby brockwood » Fri May 04, 2018 9:48 am

the early select o speeds workmaster. had a couple of free wheeling gears like an mf muilty power but not by the time of the 5 some thing would have to be broken however the t bars de tents on the valve body is like half a sprocket and can wear flats on the teeth which gives a false netural fixed at the time by giving the stick a wriggly . i use jd trans fluid in mine
1x 23f 1x 34 blue n 1 x 44 green n e27/s x 8 3ooo/ 5000 slectospeed county 754 x1 ford k series truck
brockwood
True Blue
 
Posts: 140
Joined: Fri Apr 08, 2011 2:25 pm
Location: vic australia


Return to Ford World Series

Who is online

Users browsing this forum: No registered users and 5 guests

cron